Introduction to SwitcherCAD

1 PREFACE
1.1 What is SwitcherCAD?
SwitcherCAD III is a new Spice based program that was Note 1: Linear Technology
developed for modelling board level switching regulator systems. website: www.linear.com
The program consists of a schematic capture program that allows
users to create and edit circuits, high performance Spice simulator Note 2: LTspice is a trade
mark of Linear Technology
called LTspice and a waveform viewer for displaying the simulated Corporation
waveforms. SwitcherCAD is freely downloadable from the Linear
Technology website
LTspice, simulation engine of SwitcherCAD, is a software package
based on industrial standard software for circuit simulation called
Spice (Simulated Program with Integrated Circuit Emphasis).

Note 3: Philosophy of work in
SwitcherCAD is very similar to
work in OrCad PSpice.

Spice was built in the seventies at the University of California,
Berkley and subsequently improved and rewritten to commercial
form by number of software companies. The most famous
commercial form of Spice, called PSpice, was written in 1980 by
Microsim Corporation and from 1997 is integrated in OrCad design
software package.

1.2 The structure of SwitcherCAD
SwitcherCAD incorporates three main parts:
-

Schematics Capture is used for creating end editing
schematics of analogue, digital or mixed circuits.

-

LTspice can provide several types of analysis like operating
point analysis (OP), direct current analysis (DC), alternating
current analysis (AC) and transient analysis (TRAN).

-

Waveform viewer – SwitcherCAD includes an integrated
waveform viewer.
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2LTSPICE FUNDAMENTALS
2.1 How does Spice work?
Programme Spice processes an input file which contains circuit
description and simulation commands. Input file is a simple text file
with .cir (or .net in LTspice) suffix. It is possible to create Spice input
file in any text editor. Commercial Spice based software packages
usually contain a schematics editor, which enables to draw schemes
with all necessary entries for simulation and then distil a Spice input
file. During its activity Spice generates output text file with .out (.log
in LTspice) suffix which contains a copy of input file, information
about simulation, errors and in reduced range simulation results
(operating point); then the large file (with suffix .dat or .raw for
LTspice) containing all simulation results is created. This file can be
processed by any waveform viewer (for example Probe in OrCad
PSpice package), which enables visualization of simulation data.
Even though in SwitcherCAD the three programmes mentioned above
are integrated into one executable file, the philosophy of Spice was
preserved. It is still possible to prepare the input file for LTspice in any
text editor or export simulation results to the text file.

Figure 2.1 SwitcherCAD structure

2.1.1

LTspice input file structure

A general LTspice program consist of the following components:
 Title
 Element statements
 Control statements
 End statements
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Title is the first line in the LTspice input file. It has only informational
role, it is ignored by LTspice and can be blank.

Note 4: LTspice elements
First letter
Circuit
of name
element
A Special functions
B Arbitrary behavioral
voltage source
C Capacitor
D Diode
E Voltage-controlled
voltage source
F Voltage-controlled
current source
G Current-controlled
current source
H Current-controlled
voltage source
I Current source
J JFET transistor
K Mutual inductors
L Inductor
M MOS FET transistor
O Loosy transmission
line
Q Bipolar transistor
R Resistor
S Voltage controlled
switch
T Transmission line
U Uniform RC line
V Voltage source
W Current controlled
switch
X Subcircuit
Z MESFET transistor

Comments
An asterisk ‘*’ in the first column of a line indicates a comment line.
You can use semicolon ‘;’ form commenting anywhere in your
programme.
Element statement specifies the elements in the circuit. The element
statement consist of the element name, circuit nodes to which it is
connected and the values of the parameters that characterize the
element.
Examples:
R3 N005 N003 480kOhm;

resistor declaration

V2 N003 0 12V ; independent voltage source declaration
Q1 N005 N004 0 0 NPN ; bipolar junction transistor

The element name must begin with a letter of the alphabet that is
unique to a circuit element (see Note 4).
Circuit nodes can be any string. Node 0 is predefined for the ground of
a circuit.
Elements values can be integer or floating point numbers. It is possible
to use exponential form or numbers followed by scaling factor (see
Note 5). Any character after the scaling factor abbreviation is ignored
(see examples above).

Control statements
To run a simulation, not only must the circuit be defined, but also the
Note 5: Abbreviations
type of analysis to be performed. Simulation progress is driven by
Spice suffix
Multiplaying
control statements. All control statements start with a dot, therefore
Factor
they are called "Dot commands”.
T
1012
It is possible to divide Dot commands into several categories:
1) References, commands for including or linking files
File insertion
.INCLUDE <"File name">
In the included file the first line must contain comment.
Library reference
.LIB
<"File name">
This command can be used as a reference to models or subcircuits
in any library file.

G
Meg
K
M
U
N
P
F
Mil

109
106
103
10-3
10-6
10-9
10-12
10-15
25.4 x 10-6
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2) Commands for the part or circuit properties modification
Subcircuits
.SUBCKT <"Name"> ["Node list"]
[PARAMS:("Name"="Value")]
device statements
.ENDS ["Name"]
Make possible to define a circuit. Repetitive circuitry can be
enclosed in a subcircuit definition and used as multiple
instances in the same circuit.
Models
.MODEL <"Model name"> <"Model type">
[("Parameter" = Value")]
This direction defines a set of parameters, which characterizes
properties of the concrete part. Model name can chooses
user, model type refer to standard models in LTspice.
Parameters
.PARAM <"Parameter name" = "Value or
expression">
The .PARAM direction allows creation of user defined
variables. It is possible to simply assign the same value to
several parts. Also this directive can by useful for parametric
analysis (parameter can change during repeated simulation).
Initial values
.IC <V("Node")= "Voltage value">
<I("Inductor")= "Voltage value">
For some types of analysis it is necessary to set initial
conditions like voltages in nodes or currents through inductors.
Functions
.FUNC <Name> [List of arguments]
{<expression>}
It is possible to define functions for simple usage of repetitive
part of programme. The name of user-defined functions can not
be equal to any predefined function. In expression you can use
any function defined above (or predefined).
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3. Commands for analysis control
Operating point analysis
.OP
Operating point is the steady state for direct currents and
voltages. During calculation capacitances are open-circuited
and inductances short-circuited.
Direct current (DC) analysis
.DC

<Source name> <Start value>
<Stop value> <Increment value>

The .DC control statement specifies the values that will be
used for direct current sweep analysis. It is useful for
computing the DC transfer function of an amplifier or plotting
the characteristic curves of a transistor for model verification.
Source name is the name of an independent voltage or
current source.
Alternating current (AC) analysis
.AC <lin,oct,dec> <Steps> <Start> <Stop>
The .AC control statement is used to computing the AC
complex node voltages as a function of frequency which means
it is computed both amplitude and phase.
First the DC operating point is found. Next, the nonlinear parts
are linearized in the DC operating point. Frequency of all
independent voltage sources changes simultaneously. If you
choose lin, then Steps means total number of frequencies.
If you choose oct or dec, then Steps means the number
of steps in one octave or decade.
Transient analysis
.TRAN

<Tstep> <Tstop>
[modifiers]

[Tstart

[dTmax]]

This direction enables to perform a transient analysis. This is
the most direct simulation of a circuit. It basically computes
what happens when the circuit is powered up. Test signals are
often applied as independent sources. During the computing
the variable TIME is changed from zero to Tstop. Variables
Tstep, Tstart and dTmax refer only to output to the
waveform file. Tstep is a step for printout. The step for
computation changes adaptively. If Tstart is specified, the
waveform data between zero and Tstart is not saved.
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Similarly data between dTmax and Tstop is not saved.
Fourier analysis
.FOUR <Frequency> [Nharmonics] [Nperiods]
<Data trace1> [<Data trace2> ...]
Fourier analysis computes amplitude and phase of harmonic
components of specified variables (Data trace). You can
use Fourier analysis only after transient analysis. This
direction is supported only for back compatibility. Fourier
analysis implemented in waveform viewer is more useful.
Parametric analysis
.STEP [PARAM] [LIN,OCT,DEC] <Variable>
[LIST Values] <Start> <Stop> <Step>
This command causes an analysis to be repeatedly performed
while stepping the temperature, a model parameter, a global
parameter, or an independent source. Steps may be linear,
logarithmic, or specified as a list of values.
DC Transfer function
.TF V(<Node>[, <ref>]) <Source>
.TF I(<Voltage source>) <Source>
This is an analysis mode that finds the DC small signal transfer
function of a node voltage or branch current due to small
variations of an independent source.
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WORKING WITH SWCAD

3.1 Operating point analysis
Examples in this chapter provide an introduction to the methods and
tools for creating circuit design, running simulations, and analyzing
simulation results.

Figure 3.1 Bridge circuit

3.1.1
1
2
3.1.2
1
2
3
4
5
3.1.3
1
2
3

Creating new schemes
From the Windows Start menu, choose SWCAD III.
From the File menu choose New Schematics.
Placing parts

or press F2

From the Edit menu choose Component – Select Component Symbol
dialog window appears.
Select part from list and click OK.
If you want to rotate the part press Ctrl+R.
Move pointer to the correct position and click left to place a
part.
Click right to stop placing the parts.
Connecting parts
From the Edit menu choose Draw Wire.
Click the connection point of the first part, move the pointer to
the connection point of the second part and click again.
If you want to assign a name (label) to the wire, click right on
the wire and choose Label Net item.

or press F3

or press F4
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Note: If you are preparing a scheme for simulation it is necessary to
name any net 0 or connect with the special part called GND.
3.1.4
1
2
3
3.1.5
1
2
3.1.6
1
2

Placing GND
From the Edit menu choose Place GND.
Move pointer to the correct position and click left to place
GND.
Connect GND to any net.

or press G

Editing Parts
Click right on the part.
In the dialog box which appears you can change part properties.
Deleting Parts
From the Edit menu choose Delete, scissors cursor appears.
Click on the part you want to delete.
or press F5

Operating point is a DC solution with capacitances open circuited and
inductances short circuited. Usually a DC solution is performed as a
part of another analysis. During operation point analysis the following
values are counted.
-

Voltages at each node of a circuit
Currents and power dissipation of all voltage sources in a
circuit
Transistor diode parameters, if this devices are present in a
circuit

The results of operating point analysis will appear in a dialog box.
After operating point simulation, when you point at a node or current
the solution will appear on the status bar.
3.1.7
1
2
3
4
5

Providing Operating point analysis
From the Simulate menu choose Edit simulation cmd.
In the simulation dialog box click on the DC op pnt bookmark.
Click Ok.
From the Simulate menu choose Run, dialog box with results
appears.
If you click on any node or part the result will appear in the
status line.
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3.2 Exercise
1. Determine all node voltages for given resistive circuit with
multiple sources.

2. Determine voltage on the collector of transistor for given
common-emitter amplifier.
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3.3 Parametric operating point analysis
Parametric analysis is a repeated calculation of operating point on
condition that at least one of the circuit parameters is changed. A
variance of circuit parameter can be linear or logarithmic.
Suppose a bridge circuit from the example 3.1. We can ask a question:
"How will the current through the resistor R6 change, if the resistor R2
changes. To solve this problem we have to make several changes in the
circuit from example 3.1.
If we would like the resistance of R2 to change during parametric
analysis, we have to substitute concrete value by parameter (or
variable).
3.3.1
1
2
3
3.3.2

Defining parameter
Click right on value of the R2 resistor, the dialog box appears.
Type {R} to the edit box.
Press OK

Note 5: Name of
parameter must be
between braces.

Preparing parametric analysis

It is necessary to use Spice directive .STEP (see 2.1 How does Spice
work) for performing parametric analysis in LTspice.
1
2
3
3.3.3
1
2
3.3.4

Choose Spice directive item from the Edit menu.
Type .STEP PARAM R 10 500 10 into the dialog box.
Click OK, choose suitable place on your schematics for placing
the directive and then click left.
Running simulation
From the Simulate menu choose Run, dialog box with results
appears.
Select I(R6) in the list and click OK.
Result

Problem: What will happen when R6 resistance value changes
simultaneously?
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3.4 DC sweep analysis
The DC sweep analysis causes a DC sweep to be performed on the
circuit. DC sweep allows you to sweep a source (voltage or current), a
global parameter or model parameter through a range of values.
Suppose bridge circuit from the first example (Figure 2). We can
change source voltage and observe how current trough resistor R3
changes.
3.4.1
1
2
3
4
5
6
7
8

Setting up and running a DC sweep analysis
From the Simulate menu choose Edit simulation cmd.
In the Simulation dialog box click on the DC Sweep bookmark.
Type V1 into the Name text box.
Write -10 to the Start Value text box, 10 into the Stop Value text box
and 0.1 to the Increment text box.
Press OK button.
Choose suitable place for analysis description and click left.
From the Simulate menu choose Run. Dialog box with results
appears.
From the dialog box choose values (voltages or currents) you
would like to draw.

Figure 3.2 DC sweep analysis settings
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1
2

3
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Displaying DC sweep analysis results
A new window of waveform viewer appears after simulation.
If you want to add a new trace simply click on any wire (for
adding voltage waveform) or any part (for adding current
waveform).
For deleting trace choose Delete Traces from the Plot Settings menu
and click on the trace name on the top of the waveform viewer.

displaying currents

displaying voltages

displaying
dissipation
(press Alt)
Note: You can click on one
node and drag the mouse
to another node for
differential voltage plot.

Figure 3.3 SWCAD screen with waveform viewer
It is of course possible to sweep several sources simultaneously.
Finding bipolar junction transistor output characteristics can be Note 6: In the Simulation
dialog box on the DC
mentioned as a good example of application.

sweep bookmark, you can
set up three independent
sources at the most, for
DC sweep analysis.

Figure 3.4 : Bipolar junction transistor output characteristics
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Figure 3.5 : Circuit for obtaining BJT output characteristics

3.5 Small signal DC Transfer function
This analysis can be used to obtain small-signal gain, dc input
resistance, and dc output resistance of a circuit by linearizing the
circuit around a bias point.
Example: Determine input resistance, output resistance and gain of
given inverting operational amplifier.

Figure 3.6 : Inverting operational amplifier
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Simulation

1. Create a new file and draw the circuit. Operational amplifier
LT 1001 you can find in Opamps folder.
2. It is necessary for the operational amplifier LT1001 to have
power supply. In this case it is done using labels (see figure
above).
3. It is suitable to assign labels to the output of operational
amplifier. Click right on the LT1001 output node, a local menu
appears. Select Label net from this list and then type out to the
edit box.
4. From the Simulate menu choose Edit Simulation Cmd item.
5. Click on the DC Transfer bookmark.
6. Type V(out) to the Output edit box and V1 to the Source edit box.
7. Run the simulation.

or press F4

Note 7: It is possible to
use DC transfer analysis
together with parametric
analysis.

3.6 Exercises
1. Draw the V/A characteristic of diode.
2. Suppose circuit on the figure below. Draw dependence
I RZ  f ( Rz ) . What is the use of this circuit?
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3.7 AC sweep analysis
The AC sweep analysis in SwitcherCAD is a linear frequency domain
analysis that can be used to observe the frequency response of any
circuit at its bias point.

Figure 3.7 Low pass filter

3.7.1
1
2
3
4
5
6
7
3.7.2
1
2
3

4
5
6

Note 6: Abbreviations
Spice suffix
Multiplaying
Factor
T
1012
G
109
Meg
106
K
103
M
10-3
U
10-6
N
10-9
P
10-12
F
10-15
Mil
25.4 x 10-6

Example circuit creation
Start SwitcherCAD and create new schematics.
From the Edit menu choose Component, Select Component Symbol
dialog box appears.
Select Voltage from the list.
Place Voltage source and click right, Independent Voltage Source dialog
box appears.
Click on the Advanced button.
Type 0 into the DC Value edit box, 1 into the AC Value edit box, 0
intto the AC Phase edit box and click OK.
Place and connect the other parts (see Fig. 4).
Setting up and running an AC sweep analysis
From the Simulate menu choose Edit simulation cmd.
In the Simulation dialog box click on the AC Sweep bookmark.
Type 10 into the Number of points per octave edit box, 0.1 into the
Start Frequency edit box and 10Meg into the Stop frequency edit box,
then click OK.
Choose a suitable place for analysis description and click left.
From the Simulate menu choose Run, dialog box with results
appears.
From the dialog box choose values (voltages or currents) you
can draw.
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Figure 3.8 AC analysis simulation results

3.8 Transient analysis
3.8.1
1
2
3
4

Example circuit creation
Assume low pass filter (see Fig. 4). Create new schematics and
draw the circuit. As a source use part Voltage again.
Right click on the voltage source, Independent Voltage Source dialog
box appears.
Select Pulse item from the Functions list.
Set parameters as below and click OK.
Parameter
Vinitial
Von
Tdelay
Trise
Tfall
Ton
Tperiod
Ncykles

Value
0
10
0
0.1n
0.1n
5u
0
0
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Figure 3.9 PULSE source voltage waveform

3.8.2

Setting up and running a Transient analysis

From the Simulate menu choose Edit simulation cmd.
In the Simulation dialog box, click on the Transient bookmark.
Type 4ms into the Stop time edit box, 0 into the Time to start saving
data edit box and 1u into the Maximum timestep edit box, then click
OK.
9 Choose a suitable place for analysis description and click left.
10 From the Simulate menu choose Run, dialog box with results
appears.
11 From the dialog box choose values (voltages or currents) you
can draw.
1
7
8

Figure 3.10 Transient analysis simulation results
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